page  <- 1234567891011 -> <- 1 ... 10, 11 ->
List results:
Search options:
Use \ before commas in usernames
Bangaa Bishop
Now I have one more stumper, I see a missle tank on a ledge just before the (locked) entrance to the Exam Center. Invisible walls prevent you from space jumping to it. I see a door on the far side of the room where the missile tank is, but I can't seem to find where the other side of that door comes out.
I like turtles.
The room before.  You'll see a path on the left side that looks a bit like a road.  Run along that until your Speed Booster activates, and you should break through the wall and be led to the expansion.
One shall stand, one shall ball.
God that one is so stupid, they seriously just invisible wall you for no good reason. It's one thing to put it just put of reach and hint that you can find another way there, to just put up a wall and say not you can't is lame as hell.
Bangaa Bishop
heh... I actually tried charging up that path, but I kept stopping in front of the wall to do a jump. It's amazing I didn't discover it by accident- but who would think to do that? the wall looks completely unremarkable.
You can probably target it in first person.
One shall stand, one shall ball.
You can. But it's still not something you'd really think to do in that case.
Bangaa Bishop
I still maintain they did a good job of hiding a lot of items, despite some people claiming everything was easy to find.
Well it's a pretty good idea to look around in first person if there's an item nearby, but some of them are still pretty well hidden.
Bangaa Bishop
A lot of items are tricky to find even though there's a dot on the minimap. Though this is largely because the minimap doesn't reflect the Z dimension.

It's also really annoying that the HUD minimap is so much different from the map screen (HUD minimap is much more detailed)
The dot on the map is really just a general area to search; once you reached the dot, you still had to search for the way to the item. As a matter of fact, there were a few places were I could even see an item, but couldn't get to it (looking at you, landing site missile). And if the map did show the Z dimension, the items really would be too easy to find.

The minimap really bothered me simply because it seemed to be taunting me with its detail. It doesn't seem that bad when thinking about it, but there were a few times when I really needed detail on my regular map and couldn't get it. Especially when looking for an item not directly in a visible room.
Yoshi is back
I have like, one missile expansion left and I'm clueless where to get it, In sector 2 where you fight three of those wolf-like creatures and a giant thing, on the left side as soon as you enter the room, there is the tank. go into first person view, scan it and thats it. I don't know how to get it! please tell me how.
I'm pretty sure there aren't any missile tanks in Sector 2....
Yoshi is back
There are atleast (don't doubt me on this, I'm just not sure) 15 missile expansions in each sector, but this one is in a icy morphball tunnel, I know this because I did what I said last time and underneath the item it said "Missile Tank" so yeah, I just don't know how to get it or where abouts the tunnel entrance is. I'll put up a picture on the map of where it is. 

Edit: Nevermind I found it the entrance is right here:
I like turtles.
Yeah, I hate those expansions whose methods of access aren't in the same room as the expansion.
Yep, it took me like Idk...well, all last night and this morning to find was what i have to say, one of the most annoying missile to get.
my umbrella goes directly to Bankai
with the time it cost to type that name, you could have signed up.
Yoshi is back
I know, but I didn't want too :P

Aren't I allowed to be a guest and submit things?
my umbrella goes directly to Bankai
well, all i was doing was pointing out the extra effort for the long nickname.
if you posted under "dave" or something simple like that, it would really look like you didn't have the time or were too lazy to log in.
Yoshi is back
I'm lazy, ok? I like my laziness so leave it at that ;P. Now, continuing with the help thread....

I have not yet gotten the MT, because that of my Wii has fallen on my floor and displaced the eye. i'm currently looking for assistance where as my Serial number doesn't work on the help for nintendo forum.
I'll possibly finish the game....100% 10:00+ if lucky I will finish 100% 9:59-
Bangaa Bishop
So... long time later, I'm doing other M hard mode.

Aaaaaannnnnd, I'm on the last battle, after the
The queen fight still bugs me to this day. You can grapple into her belly and pause the game, and it doesn't say you have power bombs. You never say to yourself "any objections adam" or in any way get notified that you can and should use a power bomb to win
). You are in first person and can't move, and whole bunch of enemies are coming at you. You can stop them from hitting you by firing a missile, but because you can't move, you can't concentrate, and every time, I run out of missiles and die if I wasn't dead before running out. Is there some trick to beating this that I don't know of? It was tricky on normal and on hard, it seems impossible.
Pretty sure all you have to do there is target MB and try to fire at her and the battle will end. It's been a while since I last played, but that's what I remember because it ticked a bunch of people off when they thought you had to fight your way out of the situation.
One shall stand, one shall ball.
Those bugs have an annoying habit of blocking her though, both times I played I needed to shoot them a bit just to get them out of the way. Typically it went, point where she's standing hold down B and pray you can get a lock before death.

A quick round of seeker missiles on the bugs might get you the time you need, but I'm guessing you only get one shot at that on hard.

I imagine the only reason people don't complain about that part more is that they either stopped playing before that or just mentally blocked it out because it was so stupid.
Bangaa Bishop
My gosh, I feel so stupid. I totally forgot it was just a Where's Waldo where you can die if you don't figure out that you're supposed to aim at her before you get torn apart.

(You actually can't charge up missiles in that sequence, or at least I was only able to fire normal missles for some reason- I guess that should have been a hint.
Edit history:
UchihaSasuke: 2011-09-10 12:27:08 pm
UchihaSasuke: 2011-09-10 12:23:47 pm
my umbrella goes directly to Bankai
or some people got past it way too fast to even make it register.

the first couple of times i got there, i was shooting stuff until i died. then, in one of those attempts, i locked on MB and ended the battle without knowing how i did it.
What'd you say?
Well, I picked up this game today. Please, please, please tell me that the controls are much easier to use once you get used to them! I was expecting to use the nunchuk with the Wiimote, rather than having to use just the Wiimote and having to tilt/aim it.

This is actually the first 3-D metroid that I've played more than 5 minutes of. Already, the cutscenes are getting annoying.