page  <- 12345678910 -> <- 1 .. 8 .. 10 ->
List results:
Search options:
Use \ before commas in usernames
Edit history:
Quietus: 2009-11-08 05:59:43 pm
Super Secret Area - Dead Ahead!
I downloaded the latest DoubleHelix, and replaced the .exe, like you suggested.  I got this:

Edit history:
dwarf74: 2009-11-17 08:10:21 pm
dwarf74: 2009-11-14 10:50:04 pm
DH update :) cool.

edit: works good for me :D
Yeah, not working for me, either. Damn, looking forward to that.
Edit history:
Juice: 2009-12-01 03:30:21 am
Cool a new update! I thought there weren't coming any updates.
I'm using it right now, and yeah it works fine here :D

edit: bah same crash as before if I save. Is it possible that DH crash when I save because I "changed" too much. (change is not the right word, I meant using too much clip data,level layers, etc)
Edit history:
Portalboat: 2009-12-05 07:13:56 pm
Portalboat: 2009-12-05 05:34:58 pm
I've just downloaded DH, and I can't figure out how to place the upgrades(i.e. Ice Beam, Speed Booster, etc.) I got the expansions working fine. Just no upgrades.

BTW, how do I change the tile set?

Also, how would I add a new scroll/door?

DOUBLEEDIT: It appears I can't change the clip data in MF directly - I have to copy it from somewhere else.
Edit history:
dwarf74: 2009-12-13 04:38:10 pm
i dont know anything about MF, but i know that in MZM, to place upgrades like speedbooster or ice beam, you have to find the spriteset that it's in. Just find the room the item is in, then go to spriteset editor or whatever it is and find its number. You would then just use that number in whatever room you want. I dont know anything about adding scrolls or doors :(

I can give a better desripiton later when im on my computer that has DH
To juice:
I'm not sure exactly what you're talking about, but i think i do. When you go to room options and click a layer to clear (level layer, back layer, clipdata, whatever), DONT CLICK SAVE ON THE ROOM OPTIONS TOOL. This permanently removes whatever you chose to clear in the room, and you can NEVER edit again on your ROM. If you did this, and you choose the room in DH, DH will just close. You can never edit this room again :/
If you're clearing level layers, just exit out of the room options tool after you click a layer to clear.
It'll still be cleared if you didn't click save, but you can still edit it. just use the save button on the main DH menu and you'll be fine :)
I've been wondering about 2 things to do in Zero Mission. How do I edit the suit colors, and how do I move around items already in the room? (Like Morphball, Wave Beam, and Ice Beam)
Edit history:
dwarf74: 2009-12-23 08:30:46 pm
I'm not sure how to edit suit colors...I think you have to have a program like Tile Editor Pro or somethin. I tried using it but i couldn't figure it out :(

To move around items like the morph ball or Ice beam, make sure you check the box that says "edit sprites", and uncheck the other editing boxes that say "edit level layer", or "edit clip data".
the items are sprites, so you would just click and drag the sprite from there :)
Thank you, and how come my Double Helix closes when I try to save?
it just closes whenever you press the save button on the main menu? What are you editing/doing before you save?
Do you have the "U" version of the game?
Yes, I have the U Version of the game. Anyway, is there ANY easy way to edit the suit colors? I know you can in SMILE, but I don't know where to download SMILE. Can someone point me to a Download Link for SMILE?
Super Secret Area - Dead Ahead!
SMILE is for Super Metroid, but if you want it, you can download it from the SMILE Release thread in the General Hack section.  It's stickied, so it'll be near the top.
Edit history:
Juice: 2009-12-26 09:06:38 am
Juice: 2009-12-26 09:03:29 am
Juice: 2009-12-26 08:28:39 am
To dwarf:
That's not what i meant, but thanks for the heads up. So I should never click on the save button in the room options window.
I just changed a spriteset of room 1E in norfair to 39 and made some level layer changes. It saved the changes. And if i try to save a small change (for example changing 1 block of the level or changing the clip data of 1 block), DH crashes. Is it possible that saving in the room option has a side effect after awhile? Because i can remember, using that save button once.

Edit: I just found out. DH crashes If I save (several times) adjustments, even in my back ups. I can save more often in my older back ups. I'm gonna test this on a clean zero mission rom.

Edit: I don't like my results. I tested it on a CLEAN ZERO MISSION ROM. The adjustment I made was changing the level layer of a single block. After a while, DH crashed. It's like DH has a counter and every time I save a adjustment, the counter goes up by 1. And if the counter exceeds it's limit, DH will crash. I didn't count how many times i saved adjustments, but i'd say about 250 times.
Edit history:
dwarf74: 2009-12-29 07:30:45 pm
You've probably already tried to re-download DH, huh? If you re downloaded and it still does this than i have no problem what is going on :(.
I had this problem since June. I had the same problem with different version of DH. I only tested this on the latest version with a clean mzm rom. Ahh pooy, I guess I have to stop working on my hack. (And i had such good ideas) :'(

Btw did you said you don't have this problem or don't you know how to solve this problem?
i've never had this problem (my DH has no problems at all :D), but other people stop working on their ZM/MF hacks because of random, unexplainable bugs and crashes like this :( I dont know why that happens. FRUSTRATING >:(
I really want good hacks to come out for the GBA games, but dumb stuff like this is just holdin everyone back :(
That's really odd you don't have this problem (it's actually odd I have this problem). I tried to provoke my problem 2 more times. One time i did exactly the same as before, DH freezes after 300-450 time saving. And the second time I started counting. In every room I saved 5 times and made a adjustment every time I saved. This time DH started to freeze after the 949th time I saved (oh yeah, I am that annoyed). It seems DH freezes sooner if you save more often in a room.

I have 2 questions and a request for you.
1) How do you make your rooms? Do you clear all layers and make your room out of nothing or do you adjust the room in place?
2) Whats your average in saving while creating a room?
3) (This takes 20-45 mins of your time. I understand if you don't want to do this).
Since you don't have this problem, I'd like you to provoke this problem. If you'd like to do do this, you'll need a clean mzm rom and DH off course. Don't save like a madman, before you save you need make a adjustment (for example changing a single block of the level layer). If you'd like to save in multiple rooms, save at least 50 times in a room. If my assumption is right, DH will freeze after saving 300-450 times.
Edit history:
dwarf74: 2010-01-02 12:54:31 am
dwarf74: 2010-01-01 04:07:32 pm
Uh oh, i hope this glitch doesn't eventually happen to me 0.0
...does it just happen over time?

1) I clear the layers and start from scratch. The first 2 rooms, i didnt clear the clipdata, because i was trying to figure out the program and needed something to work with.
2) lemme see... I usually do plenty of editing before saving if im just doing clipdata or level layer. Once i start with doors/sprites, I'll usually backup my ROM and edit the backup first. When i finish editing the backup without any problems, i know exactly what i want to do on the real copy. So i only actually saves 2-3 times there.
ANYWAYS (lol) ...maybe 10-25 times.
3) Well, i sure need to do this. I dont want to make too much progress in the hack if theres an unavoidable crash later on. At this point, i wont be too upset if i can't finish mine. I'll just move on to SMILE and use all my ideas there.
idk when i'll do it, but i will. Probably sometimes today.
Edit history:
dwarf74: 2010-01-03 12:19:21 am
dwarf74: 2010-01-03 12:17:04 am
dwarf74: 2010-01-02 12:53:18 am
dwarf74: 2010-01-01 05:54:36 pm
dwarf74: 2010-01-01 05:53:40 pm
dwarf74: 2010-01-01 05:52:21 pm
dwarf74: 2010-01-01 05:51:55 pm
AH! I thought i was doomed as well. I went to the #jzd IRC channel and talked to uNsane for a little while and he fixed all the problems with the save stuff.

I'll just post exactly what he instructed me to do so none of you will bump into this problem again.
You'll need a hex editor. I used xvi32. It'd probably be best if you download and use this if you're wanting to fix this problem, since the layout of others might be different.
1) Open up your ROM in the editor.
2) Go to Tools--->Options--->Appearance. Once there, change the number of columns to 16. click OK, of course.
3) Scroll all the way down, and click on the last byte.
4) Go to Edit--->Insert strings.
5) Make sure to check "hex string", and where it says "insert <n> lines", make sure decimal is checked.
6) in the box below, type in the number 25165824. Click OK, and save.
You have now changed the ROM size from 8 megabytes(i think) to 32 megabytes.
That should fix the save problems. uNsane said that as long as you don't save like a madman every time you save a block or 2, you should never have this problem again.
7) Since the ROM is expanded, you need to use USP patches instead of IPS when your hack is done.
Edit history:
Juice: 2010-01-05 04:16:12 am
This is cool, very cool :D. I thought I made my hack for nothing. But now I can make progress again.
I changed it and it works fine :D!!!
Tnx dwarf74 and uNsane.
Edit history:
dwarf74: 2010-01-05 09:13:00 pm
dwarf74: 2010-01-05 07:53:55 pm
lol, no problem.
..I have another problem, though :(. I've been having problems with one door connection, in particular. The doors CONNECT fine, but whenever i actually come through the door, unwanted things happen. I've tried and tried, but i cant get what i want.
Look at these two pictures.
(these rooms wont look anything like this.)
The first one shows the door that, on the other side, gives me problems. Whenever I walk through this door, instead of being on the ground running like i should be, I start off in the air a little bit. The second picture shows the position i start in when i enter the door. Whenever i go back to the 1st room pictured, everything works as it should...
I've tried things from putting a door capsule, fooling with door types, and changing exist distance. I dont know what else there is to do :(
I dont think door types have anything to do with it, but maybe the exist distance? or something else?
edit: I found a workaround of this problem..i didn't solve the problem. I bet it'll happen again, so itd still be appreciated.
Doors... I'm not a fan of them. I've never seen this problem.
You'd probably already checked the position of the door. I think door types only has sound effect. I don't know what exist distance is (probably  exit distance). But there are common values. For example "20" is being use for doors facing right and "C" is being used for exits (without doors) facing right. I'd recommend using one of these values with the door in the second picture. Other values also work.
Edit history:
dwarf74: 2010-01-06 07:01:31 pm
I've already messed with the exist distance a lot, but i always come out the same way. It may be the relation of the rooms, or just something wierd with that room in particular.

i've already had this problem before (although, once again, i found a workaround.)
When i drop downwards into a room, and come into the room below, i always dropped somewhat to the right side of the door. That just caused things to look wierd and wrong when i came into that room..
I need to learn EXACTLY how exist distance works lol. Maybe then, I'd be able to change it according to a wierd situation like this. I know that exist distance is how FAR away from the door you start, I dont think it can change the vertical distance from a door.
Event change 2A is the one where, near the start of the game, when you first find the ridley/kraid statue, and run across the room to where a door was blocked off, and and enemy busts through the cieling. after you kill it, the door opens.

...Is there any way known to use this in another room?